Monday, July 30, 2007

That is...

Well IE must stand for something sensible.

Having let a few select people (everybody who reads uk.rec.waterways) know about the development version of CanalPlanAC (Version 9) I've been fighting an uphill battle against the foibles of IE and it not displaying properly.

So I dragged an old Windows 98 computer out, hooked it up to a KVM switch and the router and started to get it ready to work.

I couldn't remember the password, but of course you just log on to this machine by pressing "cancel" anyway.

Well the first problem is that it didn't connect. So I found the button to change it from fixed IP to DHCP. Of course, it had to reboot then.

Then I needed to upgrade from IE4.0 (I said it was an old machine). Guess what - Microsoft's own update page doesn't render properly in IE4. You get Javascript errors, and pop-ups advertising IE7 obscuring the system description for IE6 (although it does note elsewhere on the page that you can't run IE7 on this O/S anyway).

So I upgraded to IE6. It confidently predicted a multi-hour download as it hadn't noticed the network connection. Then it rebooted again (without bothering to ask this time).

Then it told me, at reboot, that some component was too old and it some things might not work until I rebooted (remember, it just had rebooted).

Then it spend about 10 minutes showing me an animation of some drumsticks.

And people ask me why I don't use Windows! And I know that this is 98 and so must be around 7 or 8 years old now, but that's not the point. The point is, it's rubbish and always has been.

Interestingly, the tabs that have been causing all the problems appeared nicely under IE4, even if the Javascript failed! Under IE5 they have vanished. Arrrghgggggghhhhh.

0 Comments:

Post a Comment

Links to this post:

Create a Link

<< Home